Wireshark barcos en un StartupItem
que hace exactamente eso; sin embargo, la StartupItems API está en desuso:
The SystemStarter utility is deprecated. System services should instead
be described by a launchd.plist(5). See launchd(8) for more details.
The launchd utility is available on Mac OS X 10.4 and later.
In earlier versions of Mac OS X, the SystemStarter utility is used to
start, stop, and restart the system services which are described in the
/Library/StartupItems/ and /System/Library/StartupItems/ paths.
Así que, ya que estamos pidiendo "la solución más elegante", que sería el lanzamiento de un demonio.
No he probado el código siguiente, pero debe ser más o menos correcto.
Crear un archivo /Library/LaunchDaemons/com.stackexchange.apple.bpf-helper.plist
:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>com.stackexchange.apple.bpf-helper</string>
<key>ProgramArguments</key>
<array>
<string>/Library/PrivilegedHelperTools/com.stackexchange.apple.bpf-helper.sh</string>
</array>
</dict>
</plist>
Y un archivo /Library/PrivilegedHelperTools/com.stackexchange.apple.bpf-helper.sh
:
#!/bin/sh
chgrp admin /dev/bpf*
chmod g+rw /dev/bpf*
Ambos deben ser de propiedad de root:wheel
. La primera debe ser 644; el segundo 755 (600 y 700, respectivamente, probablemente va a hacer así).
Usted puede utilizar launchctl load -w /Library/LaunchDaemons/com.stackexchange.apple.bpf-helper.plist
a probarlo sin necesidad de reiniciar.